Project

General

Profile

Actions

Anomalie #1600

closed

Il n'est pas spécifié dans les nouveautés de la version 9.6 qu'il faut à présent php>=7.4

Added by Matthieu Coudert 12 months ago. Updated 12 months ago.

Status:
Fermé
Priority:
Normal
Category:
Core
Target version:
Start date:
12/01/2021
Due date:
% Done:

100%

Estimated time:
Version utilisée:

Description

Bonsoir,
mon hébergeur ne fournit que php7.3 et en voulant passer à Galette9.6 je me suis retrouvé devant un message d'erreur annonçant qu'il nécessitait php en version 7.4 ou supérieure.
Je n'ai rien vu dans le changelog de mention le spécifiant, comme lors du passage "0.9.1.2 -> 0.9.2" qui mentionnait "PHP 7.1 minimum".
J'ai heureusement pu faire machine arrière et revenir à la 9.5.2
Il serait intéressant d'avertir de cette nécessité.
Merci d'avance.

Actions #1

Updated by Johan Cwiklinski 12 months ago

  • Version utilisée changed from 0.9.6.1 to 0.9.6
Actions #2

Updated by Johan Cwiklinski 12 months ago

Le problème a également été soulevé sur la liste, il ne s'agit pas d'une modification volontaire.

Une des dépendances a fait monter la version en
7.4, mais je m'étais spécifiquement occupé de ça ; donc normalement,
c'est compatible 7.3 ; et je suppose que le delta composer vient de là.

Il suffit à priori de modifier le fichier
"galette/vendor/composer/platform_check.php" pour ne plus avoir l'erreur.

Néanmoins, le support 7.3 va prendre fin côté PHP dans quelques jours, la prochaine version (mineure ou majeure) de Galette ne la prendra plus en compte.

Actions #3

Updated by Matthieu Coudert 12 months ago

Johan Cwiklinski a écrit (#note-2):

Il suffit à priori de modifier le fichier
"galette/vendor/composer/platform_check.php" pour ne plus avoir l'erreur.

Merci, ça a fonctionné,
j'ai remplacé
if (!(PHP_VERSION_ID >= 70400))
par
if (!(PHP_VERSION_ID >= 70300))

Néanmoins, le support 7.3 va prendre fin

J'espère que l'hébergeur de notre GUL va mettre à jour (c'est Tuxfamily)

Encore merci, pour tout le travail sur Galette en général.

Actions #4

Updated by Johan Cwiklinski 12 months ago

  • Category set to Core
  • Status changed from Nouveau to In Progress
  • Assignee set to Johan Cwiklinski
  • Target version set to 0.9.6.1

Le correctif consiste à ne pas générer ce fichier qui pose problème ; je ne peux pas vraiment fournir de patch, il faut re-générer les dépendances composer.

Actions #5

Updated by Johan Cwiklinski 12 months ago

  • Status changed from In Progress to Résolu
  • % Done changed from 0 to 100
Actions #6

Updated by Johan Cwiklinski 12 months ago

  • Status changed from Résolu to Fermé
Actions

Also available in: Atom PDF