Projet

Général

Profil

Anomalie #461

generation pdf en 728

Ajouté par Michel Verdier il y a presque 5 ans. Mis à jour il y a plus de 4 ans.

Statut:
Fermé
Priorité:
Normal
Assigné à:
Catégorie:
Core
Version cible:
-
Début:
20/12/2012
Echéance:
% réalisé:

100%

Version utilisée:

Description

Hello
Me revoilà....
En 728, la generation de pdf plante: (le classique qui revient), en repassant à la 727 sur le meme répertoire ça remarche.
Erreur serveur
Le site Web a rencontré une erreur lors de l'extraction de http://galette.leclub404.com/carte_adherent.php?id_adh=2338. Cela peut être dû à une opération de maintenance ou à une configuration incorrecte.
Voici quelques suggestions :
Actualisez cette page Web ultérieurement.
Erreur HTTP 500 (Internal Server Error) : Une situation inattendue s'est produite tandis que le serveur tentait de traiter la demande.

(j'ai la reinstallé 7.2.7 sur essai.leclub404.com et conservé la 7.2.8 sur galette.leclub404.com)

Révisions associées

Révision 98fe5d19
Ajouté par Johan Cwiklinski il y a presque 5 ans

Members pictures are mandatory for cards; fixes #461

Historique

#1 Mis à jour par Michel Verdier il y a presque 5 ans

j'oubliai, les 2 pointent sur la même base.

#2 Mis à jour par Michel Verdier il y a presque 5 ans

voici le message avec le display à 1
Fatal error: Call to a member function getPath() on a non-object in /home/www/leclub404/www/galette/carte_adherent.php on line 257

#3 Mis à jour par Johan Cwiklinski il y a presque 5 ans

  • Assigné à mis à Johan Cwiklinski
  • Catégorie mis à Core

Il semble que j'aie été trop restrictif dans le ménage des dépendances chargées ; les photos ne sont pas chargées, or, on en a besoin pour les cartes...

Pour corriger le problème de façon temporaire tu peux éditer le fichier lib/Galette/Repository/Members.php, à la ligne ~502 et y remplacer picture => false par picture => true.

#4 Mis à jour par Michel Verdier il y a presque 5 ans

RE
apparemment ça me pose d'autres problèmes :
Fatal error: Namespace declaration statement has to be the very first statement in the script in /home/www/leclub404/www/galette/lib/Galette/Repository/Members.php on line 38

Et apres ça , ça me fait des choses bizarres, le serveur qui me renvoit des pages blanches 'pour tout ce qui concerne les adhérents' meme en ayant repositionné à false...
-Liste des adhérents
-affichage d'une fiche (en partant des contributions)
-liste des membres (pages publiques)....

?????

#5 Mis à jour par Johan Cwiklinski il y a presque 5 ans

Tu as repassé l'affichage des erreurs à 0 également ?

On dirait le même genre de problème que tu avais sur la génération de PDF (output already send) ; c'est comme si quelque chose avait déjà été renvoyé par le serveur avant qu'il ne cherche à charger la classe... Ou que le fichier aa été modifié avec un éditeur de texte qui a fait une bêtise (j'ai déjà rencontré ce cas de figure).

Essaies dans un premier temps de remettre le fichier d'origine voir si ça corrige ton soucis ; puis essaies de le modifier, mais avec un autre éditeur de texte que celui que tu as utilisé plus tôt (et, s'il demande, éviter à ce que j'en sais tout ce qui porterait la mention 'BOM' pour l'encodage).

#6 Mis à jour par Michel Verdier il y a presque 5 ans

Bon, en utilisant winVi au lieu de notepad;exe, j'ai le bon nombre d'octets liés au changement , ça a l'air de marcher mais en allant dans Configuration j'ai des soucis avec le mot de passe administrateur en voulant charger l'image.....

#7 Mis à jour par Johan Cwiklinski il y a presque 5 ans

Tu fais référence au message "Identifiant déjà utilisé" ? Il y a un adhérent dans la base dont le login est le même que ton super-admin (c'est pas censé arriver ça...).

#8 Mis à jour par Michel Verdier il y a presque 5 ans

ça marche pas plus 'can't generate pdf files'...
Bon je reinstalle....

#9 Mis à jour par Johan Cwiklinski il y a presque 5 ans

:-(

Bon, je reproduis le problème, je vais donc pouvoir le corriger assez rapidement... et sortir une .9 (je release plus vite que mon ombre :D).

#10 Mis à jour par Johan Cwiklinski il y a presque 5 ans

  • Statut changé de Nouveau à In Progress

Je pense que j'ai corrigé le problème (et un autre au passage) ; mais je suis un poil trop fatigué pour refaire une release maintenant ; je verrai ça demain ou ce week-end ; tu auras tes pdf pour noël :D

#11 Mis à jour par Johan Cwiklinski il y a plus de 4 ans

  • Statut changé de In Progress à Résolu
  • % réalisé changé de 0 à 100

#12 Mis à jour par Johan Cwiklinski il y a plus de 4 ans

  • Statut changé de Résolu à Fermé

Formats disponibles : Atom PDF